Error message Collections

En cas de problème lors de l'installation...

par gadgeteer » Lun 7 Mar 2011 19:00

Hello,
I like your plugin, but I am trying to get it working. I have version 0.4.1 and Joomlad version 1.5.22 Stable installed. After many trial and errors I finally got your component installed and got to see the dashboard. But when I clicked on Collections I got the following error message:

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/users/m/e/meentw/www/demo2/libraries/joomla/database/database/mysql.php on line 344

What can I do to make this warning disappear?
And when I tried to create a new collection I got the following error:
Fatal error: Call to undefined function: setredirect() in /home/users/m/e/meentw/www/demo2/administrator/components/com_collector/views/collectionedit/view.html.php on line 177

Please help me !!!

I want to use this component for my collection.

Regards,

Jouke Nienhuis
gadgeteer
 
Messages: 3
Inscription: Ven 10 Déc 2010 13:11

par steevo » Lun 7 Mar 2011 20:50

Hi,

I think that you have a problem with your database.
Are you sure you have table "jos_collector" in your database?
What problems have you encountered during install ?
Avatar de l’utilisateur
steevo
Administrateur du site
 
Messages: 330
Inscription: Jeu 17 Déc 2009 22:59

par gadgeteer » Mar 8 Mar 2011 00:01

When I installed the component I got the following error message:
DB function failed with error number 1146
Table 'meentwdb.jcm_collector' doesn't exist SQL=INSERT INTO `jcm_collector` ( `id` ,`name` ,`alias` ,`description` ,`custom` ,`state` ,`created` ,`created_by` ,`created_by_alias` ,`modified` ,`modified_by` ,`publish_up` ,`publish_down` ,`checked_out` ,`checked_out_time` ,`image` ,`access` ,`home` ,`metakey` ,`metadesc` ,`metadata` ) VALUES ( '' , 'Campeugeot', 'campeugeot', 'Voici les miniatures inédites du CAMP.', '0', '1', '2008-11-02 17:09:55', '62', '', '0000-00-00 00:00:00', '0', '2008-11-02 17:10:19', '0000-00-00 00:00:00', '0', '0000-00-00 00:00:00', '', '0', '1', '', '', '' );

When I installed Collector locally, it did work without any error message, but online it gave the error message above. What went wrong? Obviously tables were not installed during the online installation, but I do see the dashboard. How can I install the component properly?
gadgeteer
 
Messages: 3
Inscription: Ven 10 Déc 2010 13:11

par steevo » Mer 9 Mar 2011 01:18

I don't know why tables were not installed.
Do you have this problem with others components or only Collector ?

Are you sure you are allowed to create tables in the database ?
Do you have access to phpmyadmin or another database manager ?
Avatar de l’utilisateur
steevo
Administrateur du site
 
Messages: 330
Inscription: Jeu 17 Déc 2009 22:59


Retourner vers Problème à l'installation

cron

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité