tableau de bord : fatal error

Si vous détectez un bug, signalez-le ici

par ahppv » Dim 22 Jan 2012 16:38

quand je clique sur tableau de bord de collector: Fatal error: Call to a member function data() on a non-object in .../administrator/components/com_collector/views/collectors/view.html.php on line 87

la ligne en question
$last_version = $this->collectorVersions->component[0]->data();


plu autre problème bizarre :
les champs texte ne peuvent pas être modifiés en frontpage alors que les autres champs si !

??
le tout sur du Joomla! 1.5.22
cordialement
corinne
ahppv
 
Messages: 32
Inscription: Mer 23 Mar 2011 17:53

par steevo » Lun 23 Jan 2012 15:16

Bonjour,

ahppv a écrit:quand je clique sur tableau de bord de collector: Fatal error: Call to a member function data() on a non-object in .../administrator/components/com_collector/views/collectors/view.html.php on line 87

la ligne en question
$last_version = $this->collectorVersions->component[0]->data();


Je pense que c'était un problème ponctuel qui ne doit plus avoir lieu actuellement.
En fait pour savoir si la version est à jour, le programme va récupérer l'information sur un fichier hébergé chez joomlacode.org
Je suppose qu'il y a eu un problème d'accès à ce fichier ce qui a généré ton erreur.
Je prend note et modifierai pour éviter cette erreur en cas de problème d'accès.

ahppv a écrit:plu autre problème bizarre :
les champs texte ne peuvent pas être modifiés en frontpage alors que les autres champs si !

??
le tout sur du Joomla! 1.5.22


D'après les tests que j'ai fait, l'éditeur se lance mais impossible de mettre le curseur dedans. Par contre si on désactive l'éditeur, là il n'y a pas de problème. Tu me confirmes ce comportement pour toi?
Effectivement, je n'avais j'avais fait attention à cela. Je ne sais pas depuis quelle version est apparu ce problème (peut-être depuis le départ). Je testerai un peu plus en espérant corriger cela en version 0.5
Avatar de l’utilisateur
steevo
Administrateur du site
 
Messages: 330
Inscription: Jeu 17 Déc 2009 22:59

par steevo » Lun 23 Jan 2012 21:05

steevo a écrit:
ahppv a écrit:plu autre problème bizarre :
les champs texte ne peuvent pas être modifiés en frontpage alors que les autres champs si !

??
le tout sur du Joomla! 1.5.22


D'après les tests que j'ai fait, l'éditeur se lance mais impossible de mettre le curseur dedans. Par contre si on désactive l'éditeur, là il n'y a pas de problème. Tu me confirmes ce comportement pour toi?
Effectivement, je n'avais j'avais fait attention à cela. Je ne sais pas depuis quelle version est apparu ce problème (peut-être depuis le départ). Je testerai un peu plus en espérant corriger cela en version 0.5


Alors je comprends pourquoi je n'avais jamais vu ce problème: cela semble venir du template et seulement sous chrome. Le template de mon site de dev et du site sur lequel j'utilise cette fonctionnalité ne présente pas ce problème.
Peux-tu me confirmer que tu es sous chrome? Peux tu tester avec un autre navigateur?
Si c'est bien ça, je ne suis pas certain de trouver une solution... d'autant que Joomla 1.5 arrive en fin de vie et la version 0.5 de collector sera la dernière compatible Joomla 1.5.
Avatar de l’utilisateur
steevo
Administrateur du site
 
Messages: 330
Inscription: Jeu 17 Déc 2009 22:59

par ahppv » Ven 27 Jan 2012 14:40

salut

encore merci pour ta réactivité !

concernant l'erreur fatal, je l'ai toujours mais j'ai changé de ligne
Fatal error: Call to a member function data() on a non-object in /mnt/154/sda/0/7/histoirepatrimoine/administrator/components/com_collector/views/collectors/view.html.php on line 88

pour l'accès en frontpage, tu as raison, il s'agit d'un problème de navigateur car sur IE cela marche (mais pas sous mozilla firefox et pas sous chrome...)
ahppv
 
Messages: 32
Inscription: Mer 23 Mar 2011 17:53


Retourner vers Rapport de Bugs

cron

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités